Drop support for DVB_API version 1, and properly check version
authorMike Looijmans <milo-software@users.sourceforge.net>
Mon, 7 Sep 2015 17:48:16 +0000 (19:48 +0200)
committerMike Looijmans <milo-software@users.sourceforge.net>
Mon, 7 Sep 2015 17:48:16 +0000 (19:48 +0200)
commit8db90a8692582e4f180490aa24afe44fae0c3116
treeda83c46f44fb09fe70359fb3bf012052cc12d484
parent6bb792d4d76c0376e961afa3a1576a0c71e28136
Drop support for DVB_API version 1, and properly check version

E2 won't work with v1 anyway, so make that explicit. Also fixes the failure
to detect the version in the configure stage. Just include the version
header and detect it there, instead of relying on autotools.

This fixes E2 failure to compile with recent OE versions (GCC 5.2).
lib/dvb/volume.cpp
m4/tuxbox.m4